Support Forums

Unable to open User…
 
Notifications
Clear all

Unable to open Users form since update to 3.2.0340

9 Posts
2 Users
0 Likes
311 Views
Posts: 0
 Anonymous
Topic starter
Joined: 53 years ago

I have this morning applied the update to version 3.2.0340.

This fixed the issue with the reports and retention policies I had reported, however, if I try to open any user in any company I now receive a 500 error.

 

The server encountered an unexpected condition which prevented it from fulfilling the request. Details can be found below:
Nancy.ViewEngines.Razor.ViewRenderException: Unable to render the view. Most likely the Model, or a property on the Model, is null —> System.NullReferenceException: Object reference not set to an instance of an object. at CloudPanel.CPStaticHelpers.EncodeText(String text) at RazorOutput.RazorView.Execute() at Nancy.ViewEngines.Razor.NancyRazorViewBase`1.ExecuteView(String body, IDictionary`2 sectionContents) — End of inner exception stack trace — at Nancy.ViewEngines.Razor.NancyRazorViewBase`1.ExecuteView(String body, IDictionary`2 sectionContents) at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2](CallSite site, T0 arg0, T1 arg1, T2 arg2) at Nancy.ViewEngines.Razor.RazorViewEngine.<>c__DisplayClass9_0.<RenderView>b__0(Stream stream) at Nancy.ViewEngines.Razor.HtmlHelpers.Partial(String viewName, Object modelForPartial) at RazorOutput.RazorView.Execute() at Nancy.ViewEngines.Razor.NancyRazorViewBase`1.ExecuteView(String body, IDictionary`2 sectionContents) at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2](CallSite site, T0 arg0, T1 arg1, T2 arg2) at Nancy.ViewEngines.Razor.RazorViewEngine.<>c__DisplayClass9_0.<RenderView>b__0(Stream stream) at Nancy.ViewEngines.Razor.HtmlHelpers.Partial(String viewName, Object modelForPartial) at RazorOutput.RazorView.Execute() at Nancy.ViewEngines.Razor.NancyRazorViewBase`1.ExecuteView(String body, IDictionary`2 sectionContents) at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2](CallSite site, T0 arg0, T1 arg1, T2 arg2) at Nancy.ViewEngines.Razor.RazorViewEngine.<>c__DisplayClass9_0.<RenderView>b__0(Stream stream) at Nancy.Responses.MaterialisingResponse.PreExecute(NancyContext context) at Nancy.NancyEngine.<InvokeRequestLifeCycle>d__22.MoveNext()
 
I have tried this with several companies and several users, and the result is the same with them all.
 
Did I miss a step?  or do I need to roll back to the previous version?

Many thanks

Topic Tags
8 Replies
Jacob Dixon
Posts: 1453
Admin
(@jdixon)
Illustrious Member
Joined: 8 years ago

Can you try recycling the CloudPanel application pool and tell me if it does it again? 

After you do that and try to reproduce, can you gather the log files and upload them to https://compsysar.sharefile.com/r-r628e5be9c5314b7a9007c4a9fa4797c4

Reply
2 Replies
 Anonymous
Joined: 53 years ago

Posts: 0

@jdixon will try to recycle it now.

Reply
 Anonymous
Joined: 53 years ago

Posts: 0

Recycling did not resolve the issue.

Reply
Jacob Dixon
Posts: 1453
Admin
(@jdixon)
Illustrious Member
Joined: 8 years ago

Actually, can you tell me if any of your retention policies have a blank description?

Reply
4 Replies
 Anonymous
Joined: 53 years ago

Posts: 0

@jdixon None that I am aware of.  But I have only assigned a retention policy to a couple of users, but I cannot seem to open any users, even ones I have note assigned a policy to.

But I will double check all the rules and policies, to ensure all have descriptions.

Reply
 Anonymous
Joined: 53 years ago

Posts: 0

Ok, that fixed it.  I found a system generated policy that had no description.  I added the description, and that resolved the problem.

I suspect others may fall into this trap also.

Reply
Jacob Dixon
Admin
(@jdixon)
Joined: 8 years ago

Illustrious Member
Posts: 1453

@marklft Yeah, I’m fixing it right now and publishing a new update before too many get it :-\

Reply
Jacob Dixon
Admin
(@jdixon)
Joined: 8 years ago

Illustrious Member
Posts: 1453

@marklft I’m thinking one of your retention policies for that company or global does not have a description and that may be what is throwing it off. We will fix that but just want to make sure that is the issue.

Reply
Share:
X