CloudPanel 3.1.0.40...
 
Notifications
Clear all

CloudPanel 3.1.0.40 on a Server 2016 domain controller  

  RSS

bchandler
Active Member
Joined: 3 years ago
Posts: 18
2020-05-07 15:14  

Yes, I know, I know, we are using a REALLY old version of CloudPanel. I'm working on getting my boss to approve the upgrade.

However, we are running it on a Server 2012 R2 domain controller and was curious if upgrading it (in place) to Server 2016 would cause any issues. We are running Exchange 2013 and are planning on further upgrades to that as well but wanted to start with the domain controllers.

 

--Brian


Quote
Jacob Dixon
Noble Member Admin
Joined: 6 years ago
Posts: 1098
2020-05-07 15:17  

I've done many in-place upgrades on domain controllers and they always went fine, but never one with IIS. It should work without any issues though because CloudPanel uses .NET framework 100%. So as long as you install .NET 3.5 feature from server manager then you should be fine. Take snapshots / backups though just in case! 🙂


ReplyQuote
bchandler
Active Member
Joined: 3 years ago
Posts: 18
2020-05-07 16:23  

I've done in-place upgrades on domain controllers, but I guess my question is will CloudPanel 3.1.0.40 have any issues running on Server 2016? You said as long as it is running .NET 3.5 it should be fine, correct?

Either way, I'll take snapshots. 🙂

 

--Brian


ReplyQuote
bchandler
Active Member
Joined: 3 years ago
Posts: 18
2020-05-11 14:54  

FYI, no issues upgrading the server OS from 2012r2 to 2016. Thanks!

 

--Brian


ReplyQuote
Share: