Cloud panel upgrade path help  

  RSS

bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-23 15:47  

Hello,

I have inherited an Exchange 2013 standard server on a Windows Server 2012 R2 server.  It has Cloud Panel 3.0.901 installed and Cloud Scheduler 1.2.5.  I am moving to Exchange 2016 on a new Windows Server 2016 Standard server and I would like to move the Cloud Panel over to the new server.  I can't install v3.0.901 on the Windows 2016 server because it uses IIS 10.  Should I upgrade the Exchange 2013 server Cloud Panel to the latest version first and then move the folders over or do I have to upgrade the 3.0.901 to 3.1 first and then to the latest?

Thanks!


ReplyQuote
Jacob Dixon
(@jdixon)
Prominent Member Admin
Joined: 4 years  ago
Posts: 872
2018-05-23 16:14  

You will need to upgrade to 3.1 on the current server and login to make sure it all looks correct. Then you install the same version on the new server but make sure you specify a DIFFERENT database. Specifying a different database will cause it to create a new database which you will delete later. 

Now that CloudPanel is installed on the new server copy the settings.xml file over to the new server. Then you should be good.

If you need to move the database you can move it and update the settings.xml file with the new connection strings. 

Also when upgrading Exchange just make sure you point CloudPanel at the latest version of Exchange when you are in co-existence.


ReplyQuote
bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-23 16:25  

Thank you!


ReplyQuote
bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-23 16:50  

So this is what I got when I tried to do the upgrade.

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'CloudPanel.Global'.

Source Error:

 

Line 1: <%@ Application Codebehind="Global.asax.cs" Inherits="CloudPanel.Global" Language="C#" %>

 

Source File: /CloudPanel/global.asax Line: 1

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1590.0


ReplyQuote
Jacob Dixon
(@jdixon)
Prominent Member Admin
Joined: 4 years  ago
Posts: 872
2018-05-23 17:03  

What version of .NET do you have on that server? Also did you install v3.1.0030 RC first and login? When going from 3.0 to 3.1 you need to install the release candidate first.

If you would like to schedule time we can help perform the upgrade for you. If you don't have support we will invoice for one hour because that is about how long it would take.


ReplyQuote
bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-23 17:09  

.net 4.6.2 and yes I installed the RC and the error is what I got when I tried to login.  What is the cost of an hour labor?


ReplyQuote
Jacob Dixon
(@jdixon)
Prominent Member Admin
Joined: 4 years  ago
Posts: 872
2018-05-23 18:26  

Can you email sales@knowmoreit.com ?

Also I wonder if the upgrade didn't replace some DLL files based on that picture. Have you tried restarting after the update to see if that made a difference?


ReplyQuote
bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-24 09:40  

Thanks, Justin.  I'll contact them.  One last question.  If I just install a new instance of Cloud Panel on my new server what would I be losing?  Historical data from the database?  I'm thinking that this might be the best way to go instead of trying to upgrade and move.  I don't have a lot of clients on this at this time.

Thanks for you help with this.


ReplyQuote
Jacob Dixon
(@jdixon)
Prominent Member Admin
Joined: 4 years  ago
Posts: 872
2018-05-24 14:50  

Yes you would lose historical data but honestly going from 3.0 to 3.2 will cause you to lose some of that historical data anyways. If you do start new then you will need to import existing users in Active Directory into the new install:  http://kb.knowmoreit.com/configuring-cloudpanel/migrate-objects-to-cloudpanel/

There is a bugfix released for the latest version where it doesn't import users with the mailbox enabled though. We can provide that to you when you are ready.


ReplyQuote
bfadmin
(@bfadmin)
Eminent Member
Joined: 6 months  ago
Posts: 23
2018-05-24 14:54  

Thanks, Jacob.  I sent an email asking for support quote.  I tried the company import but the even though it imported it isn't visible as there is no reseller.


ReplyQuote
Share:
  
Working

Please Login or Register