SQL Instance not found after upgrading to v3.2.0292.3  

  RSS

0

Hi

Afer upgrading from 3.2.02830.2 to 3.2.0292.3, i was unable to log on to the panel.
Accessing the setup page on the server itself also faile with an error message, that it's unable to connect to the sql instance.

I checked the contents of the file C:\Program Files (x86)\Know More IT\CloudPanel\Config\settings.xml, and found, that it had ben reset to defaults.
So i restored the file from the backup of the previous version and restartet the iis service.
Everything seems to be working right now.

Are there any problems expected when we us the settings.xml from the previous version?

 

It should have kept the data in the settings.xml during the upgrade. The only value used in settings.xml anymore is the SQL connection string, so there is no problem resetting it.

0

Well, it didn't 🙂
In fact, it was a complete new file, with generic values:

.....

<?xml version="1.0" encoding="utf-8"?>
<cloudpanel>
<Settings>
<Database>server=LAB-DC01.lab.local\SQLEXPRESS;database=CloudPanel;uid=sa;password=Password!;</Database>
<CompanyName>Know More IT</CompanyName>
<HostingOU>OU=Hosting,DC=lab,DC=local</HostingOU>
<UsersOU> </UsersOU>
<PrimaryDC>LAB-DC01.lab.local</PrimaryDC>
<Username>LAB\Administrator</Username>
<Password> </Password>
<SuperAdmins>Domain Admins</SuperAdmins>
<BillingAdmins>Domain Admins</BillingAdmins>
<ResellersEnabled>true</ResellersEnabled>
.....

 

I don't currently have an answer for you. We will have to look into why the installer didn't copy the data over and see if we can reproduce it. 

0

It looks like everything ist working with the restored settings.xml, except for one thing, when i try to manually refresh the "Mailbox Databases" view on the Dahsboard, it throws the follwing error (see Attachment for a screenshot):

"Error: Coennection to remote server <<internal FQDN of Exchange Server>> failed with the follwoing error message: Illegal operation attempted on a registry key that has been marked for deletion. For more information, see the about_Remote_Troubleshooting Help topic."

 

 
0

Update: Since i wasn't able to login with our billing admin anymore, which worked right after the upgrade, i have rebooted the Server, now the login with our billing admin is working again, but the error, when trying to manually refresh the "Mailbox Databases" view on the dashboard, has changed to the follwing (see attachment for screenshot):

"Cannot implicitly convert type 'System.Collections.Generic.List' to 'Syste,Collections.Genereic.List'"

 

I confirmed there it is indeed a problem. You can use the menu at the top right to go to the databases view and refresh from there and also the CloudPanel service will keep it refreshed. We will fix the issue you discovered today.

 

Share:
  
Working

Please Login or Register