Adding Public Folde...
 

Adding Public Folder Mailbox - no Root Folder created  

   RSS

0

We are using CP V 3.2.0311.0 in an environment with 2 Exchange 2016 and 2 DCs.

When adding a new Public Folder Mailbox and specifying the name for the root folder, the root folder is visible in CP under

Dashboard - (Tenant) - Exchange - Public Folders, I can click on it and select "Modify"

But when I try to create a subfolder, I gett error message stating that the root folder doesn't exist and therefore the subfolder can't be created.

In Exchange ECP the missing root folder also is not shown.

It makes no difference if I'm manual syncing of DCs after each step above.

 

Current solution(?) is to create the public root folder in ECP, of course using exactly the same name as before.

The folder permissions need to be corrected manually (PowerShell).

After that the folder can be used in CP, subfolder creation is possible.

 

What can I do to get the folder created by CloudPanel?

 

PS: I know the infos at

https://kb.knowmoreit.com/configuring-cloudpanel/configuring-and-using-public-folders/

 

There is a checkbox stating "Do not update Exchange when saving". Are you unchecking that?

Topic Tags
6 Answers
0

I started over - I deleted the whole company and verified in Ad and Exchange that no pieces were left.

I created the company newly from scratch.

I mail enabled it and created a user account with mailbox and email address.

Then I created the public folder mailbox again.

In none of the dialogs I could find the checkbox stating "Do not update Exchange when saving".

After that I verified the things in Exchange and in AD (with ADSI Edit) - here's the result compared to the action list in

https://kb.knowmoreit.com/configuring-cloudpanel/configuring-and-using-public-folders/

 

OK -> Create a PublicFolderAdmins@ and PublicFolderUsers@ security distribution groups
OK -> Add Admins@CompanyCode to PublicFolderAdmins@CompanyCode
OK -> Add AllUsers@CompanyCode to PublicFolderUsers@CompanyCode
OK -> Create a new public folder mailbox and apply limits based on the public folder mailbox plan
NOT OK -> Create a new root public folder in the new public folder mailbox using the name you provided in the Root Public Folder Name field
NOT OK -> Add the PublicFolderAdmins and PublicFolderUsers security groups to the new root public folder for the company
OK -> Update the DefaultPublicFolderMailbox attribute for all users within the same company to the new public folder mailbox that was created.

Seems, that changes are made to Exchange - with the exception of creating the public root folder.

The "not existing" public root folder is shown in CP.

Is there any way to get the command which is used to create the public root folder to test and debug it from Exchange Shell?

Where nan I find the checkbox referred above?

@pncsupport the log files in CloudPanel should give us some more details. In the version that was just released 3.2.0315 we did put more a tim delay between when the public folder mailbox was created and when it tries to create the root public folder. There was an issue with multiple domain controllers where it would try to create the folder before it replicated to all the DC's and throw an error. The "Do not update Exchange when saving" is only shown when you modify a public folder mailbox. If you click Modify -> Edit you can set the root folder name which it should try to create it.

0

Failed to do this - "object not found" in some variations.

So I tried to delete the whole company again. I'm told "No such object found on server".

I can't delete the company in CP.

Now I deleted it in AD, but I cannot get out it from CP data.

How can I get rid of the company in CP?

@pncsupport if it was removed on the backend then it will have to be manually removed out of the CloudPanel database. If you are familiar with SQL management studio, you can go to the cp_Companies table and manually delete from there.

0

Still no success.

I deleted companx in cp_Companies, Domain of the company in cp_Domains and companys groups in ad_SecurityGroups.

(Company user I was able to delete before in CP.)

I synced the AD.

I created company and domain.

I mail-enabled company.

I created a user with mailbox.

After every step I synced AD manually and verified that the changes were visible on the second domaincontroller.

I created a Public Folder Mailbox for the company. That takes CP a while to complete but returned without error message. AD-sync again.

CP showed Public Root Folder - Exchange ECP shows no Public Folder for the company.

I modified the Public Folder Mailbox - I changed the name of the root folder and unchecked the checkbox to get the changes into Exchange. AD-sync again.

CP succeeded - but still no public folder for the company in Exchange ECP.

I again modified the Public Folder Mailbox - I changed the name of the root folder and unchecked the checkbox to get the changes into Exchange.

CP returns error message: Cannot find the root folder and therefore it cannot rename it.

Strange that the first modification succeeded when the public folder also was not created...

In the attached logfile the problems are visible - I think, it's still a problem caused by replication delay.

I marked the first problematic lines in the logfile with ####1 and ####2 

I don't know if it's possible to trigger AD replication within the scripts, all I found was this here:

https://sid-500.com/2017/10/14/active-directory-force-replication-of-all-domain-controllers-on-all-sites-at-once/

Is it possible to retrieve the PowerShell Commands issued by CP?

This would enable me to create the public folder after manually doing an AD sync so, that all settings are correct for CP.

@pncsupport Please update to version 3.1.0315 that was just released to see if it is still an issue. If it is, I would like to connect and take a look.

0

I guess you meant 3.2.0315, not 3.1.0315?

I already had updated to 3.2.0315 when doing the test - see attachment.

In that case I'd like to connect and look at the issue. Also you can get rid of that CloudPanel Scheduler in that picture

0

Ok, thank you. 

To connect is possible, best at Monday 23rd,  Tuesday 24th or Friday 27th, after 10:00 am MEST (Vienna).

You can contact me here or by office phone +43 2956 7001-44

If other days or time required, please tell me.

I uninstalled the scheduler service.

This post was modified 3 months ago by PNCSupport

@pncsupport can you please email me directly at jdixon@knowmoreit.com?

0

I just sent an email to you.

Share:

Please Login or Register